The Records Center is not properly configured for this request

This is an interesting issue – The Records Centre site template in SharePoint is available at all levels (as the Primary site of a Site Collection and as a sub-site). Problem is, when you set it up as a sub-site (as I did to run some functionality tests) it worked fine as an unconfigured Records Centre withy all submitted records going into the "Unsorted" Document Library… but as soon as you put a Routing rule in the Routing table, it throws the following error – ‘The Records Center is not properly configured for this request’.

It appears as though the security groups required for the Records Centre to work are not created when the RC is created as a Sub-site. What’s annoying is that Microsoft have set up other site templates to not be available for a sub-site, but not the Records Centre – even though it clearly cannot run as anything but the primary site in a Site Collection. Admittedly, if you are setting it up for the enterprise, you would only have it configured as a separate site collection to maximise portability…

Ah well, it’s better in 2010…

Advertisements

About Brad Saide

I'm a SharePoint consultant. I'm also slowly going bald, seem to have a permanent spare tyre around my waist and enjoy socialising with friends over a beer or 10. The last 2 may possibly be related. Started working with SharePoint when the first version was in limited beta release (participated in the Technology Adoption Program while at Woolworths) and have been committed to the adoption of the technology as a business enabler ever since.
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s