Deleting Service Application SharePoint 2010 hangs

When trying to delete a service application in Sharepoint 2010 from the central admin, sometimes you will find it just stays on the ‘processing’ window for hours (if you wait that long).

If it does you can try & delete the service application using Powershell:

Remove-SPServiceApplication

If that command doesnt work you can force the deletion by using STSADM:

STSADM -o deleteconfigurationobject -id {ID}

The above STSADM command is not documented by Microsoft (or doesnt seem to be) but it works!!!

Advertisements

About Brad Saide

I'm a SharePoint consultant. I'm also slowly going bald, seem to have a permanent spare tyre around my waist and enjoy socialising with friends over a beer or 10. The last 2 may possibly be related. Started working with SharePoint when the first version was in limited beta release (participated in the Technology Adoption Program while at Woolworths) and have been committed to the adoption of the technology as a business enabler ever since.
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s